[hnsドキュメント]

ハイパー日記システム Version 2.20

ハイパー日記システムのアップグレード


hns をアップグレードする

アップグレードの場合も, 初めてのインストールと変わりません. ハイパー日記システムのインストール を参照の上,インストールしてください. 過去の日記が消えてしまうことはありません.

hns-1.x での設定ファイル ~/public_html/diary/config.phtml, config.php3 は hns-2.00以降 では使用できません.theme.phtml, theme.php3 も同様に互換性がありません.

デフォルトのテーマは japanese です。

仕様上の変更点の詳細は,hns-2.10-pl1 からの仕様変更, をご覧願います.

必要と思われるファイルは,「ファイル名-old」として 保存されます.特に,設定ファイル config.phはconfig.ph-oldとして保存され,config.phには 新バージョンのデフォルト値が上書きされますので,注意して下さい.


hns-1.x のファイルを削除したい場合は,ウェブ日記ディレクトリに 移動して,

$ cd ~/public_html/diary
$ rm -f *.phtml *.php3
などとして削除してください.


ハイパー日記システム Version 2.20


Index